Dudas y recursos para programas que no están en ninguno otro de los foros.
Avatar de Usuario
por JuanAntonio
#3871 Al intentar cargar el proyecto del capitulo 1 del curso, Xcode me dice que está escrito en swift 2 y necesita mínimo swift 3, he mirado en el foro y hay mas personas que tienen el mismo problema pero no le han resuelto el problema o no está en el foro la solución, por favor necesito una solución de como actuar.
Gracias.
Avatar de Usuario
por Richard
#3874 Buenas Juan Antonio, a ver si entiendo a lo que te refieres: al descargar e proyecto del capitulo 1 esta en SWIFT 2 y para poder realizar el proyecto el programa te pide que este escrito en SWIFT 3 ¿cierto? entonces tu conclusión es que los archivos del proyecto están en una versión no compatible con el programa ¿no es verdad?
Avatar de Usuario
por JuanAntonio
#3876 Este es el mensaje que me da:

The targets “firstApp” and “firstAppTests” contains source code developed with Swift 2.x. Xcode 9 does not support building or migrating Swift 2.x targets.

Use Xcode 8.x to migrate the code to Swift 3.
Avatar de Usuario
por JuanAntonio
#3878 Perdona, no entiendo, me estas dando vueltas sin contestarme, creo que te dije claro lo que pasaba desde el primer momento, en mi ultima respuesta te envié lo que me aparece cuando intento cargar el proyecto en Xcode9, en esa respuesta ya aparece la versión, uso el único descargable desde el apple store, si eres tutor de programación iOS, sabras que Xcode es el último, es Xcode9 v9.4.1. De verdad que tus respuestas me hacen desconfiar del curso. He pagado por una "asistencia individual" con respuestas en 24H pero tus únicas respuestas son confusas. como si no supieses de que estamos hablando. Ademas he visto en el foro otras personas han hecho la misma pregunta en otras ocasiones y se les contestaba de la misma forma, pero en ningún momento se les ha dado una respuesta concreta. Por favor necesito una respuesta. ¿como puedo abrir los proyectos descargados de vuestro curso con Xcode9?
Avatar de Usuario
por JuanAntonio
#3888 He pagado para que un tutor me conteste en menos de 24H a mis dudas, Por favor, ¿puede ayudarme con el problema que llevo 3 días, desde que empecé el curso? intento abrir el proyecto descargado en el XCode9 y me dice que necesito migrarlo a swift3.
Gracias.
Avatar de Usuario
por Rocaro65
#3909
Richard escribió:Me puedes especificar la versión del programa que tu estas usando ¿por favor?


Hola Richard buenas tardes yo tengo el mismo problema que JuanAntonio, la version de Xcode que tengo instalada es la 9.4
y swift 4.2.
No hay manera de descargar Xcode 8 ? De todas formas cuando he comprado este curso ponía bien claro que esta actualizado a 2018 y la version de Xcode y swift de septiembre 2018 es la que yo tengo.
Podemos configurar el Xcode 9.4 y swift 4.2 para que sean compatibles con archivos de Xcode 8 y Swift 2 ?

Gracias de antemano me mantengo a la espera